Bladuino – das kleine elektronische Gehirn

Gestern sind meine 10 Bladuino Pro mini angekommen. Der Bladuino ist, wie der Name vermuten lässt, ein Arduino-Klon.

Entstanden sind die Bladuino in einem Crowdfunding Projekt auf Indiegogo.


Ein Adapter zum Programmieren der Bladuinos war auch dabei. Dieser ist notwendig, da der Bladuino keine eigene USB-Schnittstelle hat. Der Adapter ist ein CP2102 von Silabs. Die Treiber gibt es hier: Treiberdownload beim Hersteller

Die Programme werden gewohnt über die Arduino IDE geschrieben und zum Bladuino hochgeladen. Hierbei muss man ein paar Dinge beachten.

Das richtige Bord auswählen: Der Bladuino ist ein Arduino Pro Mini 5 V mit einem ATmega 328
Port: Hier muss der vom System vergebene Port für den Adapter eingetragen werden. Wenn in der IDE sehr viele Ports angezeigt werden, kann man entweder im Gerätemanager den Port nachschauen, oder man zieht den Adapter einmal vom Computer ab und guckt nach, welcher der vielen Ports nicht mehr angezeigt wird. Danach den Adapter wieder reinstecken und Port wählen.

Der Adapter muss auch noch mit dem Bladuino verbunden werden. Laut Bladuino Projekt gilt folgende Belegung:

Pin-Belegung für den USB Adapter

Bladuino

Hier begannen dann meine Probleme. Nachdem ich den Adapter wie auf dem Bild gezeigt mit dem Bladuino verbunden habe, bekam ich immer eine Fehlermeldung, wenn ich ein Programm zum Bladuino transferieren wollte.

stk500_getsync(): not in sync: resp=0x00

In diversen Foren fand ich verschiedene Lösungswege, die bei dir jedoch nicht halfen. Dort wurde immer wieder darauf hingewiesen, dass man das richtige Bord und den richtigen Port auswählen muss. Dies war bei mir auf jeden Fall richtig eingestellt. Treiber waren auch installiert und Windows hat den Adapter erkannt. Auch mehrmaliges Versuchen inklusive ab und wieder einstecken des Adapters half nicht.

Dann fand ich den Hinweis, dass man bei einigen Bords einen manuellen Reset durchführen muss, wenn man ein Programm hochladen möchte. Eigentlich sollte das beim Bladuino nicht nötig sein, da dieser über einen Soft-Reset (Pin RST am Adapter) resettet werden soll. Also habe ich zu verschiedenten Zeitpunkte während des Hochladens den Resetknopf am Bladuino gedrückt. Es half einfach nicht!

Langsam begann ich glaube, dass der Adapter nicht richtig funktioniert, da dort die Daten LED niemals aufleuchtete. Dies lies mich vermuten, dass der Adapter keine Daten sendet. Aus Verzweiflung habe ich RX und TX auf einer Seite getauscht. Erst brachte es keinen Erfolg, aber als ich dann noch den manuellen Reset gemacht habe, wurde das Programm endlich übertragen.

Es traten also zwei Fehler auf

  • es muss ein manueller Reset durchgeführt werden
  • RX und TX sind an irgendeiner Stelle vertauscht

Der Bladuino hat noch jeweils einen weiteren Pin für RX und TX. Auch dort muss ich den Anschluss vertauschen. Es scheint so, als wäre die Beschriftung auf dem Adapter falsch.

Den Draht für RST (Reset) brauche ich nicht mehr anschließen, da eh ein manueller Reset durchgeführt wird. Schaden tut der Anschluss jedoch nicht. Die 5V des Adapters kann man statt mit dem RAW Pin des Bladuino auch mit VCC des Bladuinos verbinden. An den RAW Pin kann man bis zu 12 V anlegen. Dieser ist also ein bisschen sicherer, wenn die Eingangsspannung nicht geregelt ist. Bei dem Adapter sind die 5 V aus dem USB Anschluss stabil genug, um die direkt an VCC anzulegen.

 

EDIT 229.03.2014
Die Ersteller des Projektes haben nun eine eigene Seite erstellt: http://bladuino.com/

 

Getagged mit: , , , ,